TABLAS

advertisement
TABLAS
Insertar una tabla
Para insertar una tabla hay que dirigirse al menú Insertar, a la opción Tabla.
En la nueva ventana habrá que especificar el número de Filas y Columnas que tendrá la tabla, así
como el Ancho de la tabla.
El Ancho puede ser definido como Píxeles o como Porcentaje. La diferencia de uno y otro es que el
ancho en Píxeles es siempre el mismo, independientemente del tamaño de la ventana del
navegador en la que se visualice la página, en cambio, el ancho en Porcentajeindica el porcentaje
de la página o del elemento contenedor) y se ajustará al tamaño de la ventana del navegador, esto
permite que los usuarios que tengan pantallas grandes, aprovechen todo el ancho de pantalla.
Grosor del Borde indica el grosor del borde de la tabla en píxeles, por defecto se le asigna uno (1).
Si lo ponemos a 0 o en blanco, la tabla no mostrará borde.
Relleno de celda (cellpadding) indica la distancia entre el contenido de las celdas y los bordes de
éstas.
Espacio entre celdas (cellspacing) indica la distancia entre las celdas de la tabla.
Seleccionar elementos de una tabla
Existen varias formas de seleccionar una tabla. Una de ellas es a través del
menú Modificar estando el punto de inserción en la tabla, o desplegando el menú contextual de la
tabla al pulsar con el botón derecho sobre ella. En ambos casos aparece la opción Tabla, a través
de la cual se puede elegir la opción Seleccionar tabla.
También es posible seleccionar una pulsando con el ratón sobre el borde exterior que la rodea, o
pulsando <table> que aparece en la barra de estado de la ventana de documento.
Cuando se selecciona una tabla o cuando se coloca el cursor sobre cualquier parte de la tabla,
Dreamweaver muestra en una zona verde el ancho de la tabla y de cada columna. Junto a los
anchos se encuentran unos menús desplegables (menú de encabezado de la tabla y menú de
encabezado de la columna). Estos menús permiten acceder rápidamente a determinados
comandos relacionados con la tabla.
PROPIEDADES DE LA TABLA
El inspector de propiedades muestra las propiedades de la tabla cuando la seleccionamos.
Para especificar propiedades de tabla:
Seleccionar la tabla.
Elegir Menú Ventana > Propiedades para abrir el inspector de propiedades.
Hacer clic en la flecha de ampliación, situada en la esquina inferior derecha, para ver todas las
propiedades.
Este es el Inspector de Propiedades:
Que corresponde a esta tabla:
Para seleccionar opciones de diseño de tabla:
Modificar los distintos campos:
Filas y Cols: especifica el número de filas y columnas de la tabla.
An y Al: especifica la anchura y la altura de la tabla como un número de píxeles o
como porcentaje de la ventana del explorador. Normalmente no es preciso especificar la altura de
una tabla.
Alinear especifica cómo debe alinearse una tabla con otros elementos del mismo párrafo, como
pueden ser texto o imágenes.También se puede elegir la alineación predeterminada del
explorador.
Espacio V y Espacio H, especifica el número de píxeles de espacio en blanco que habrá por encima
y por debajo, así como a los lados de la tabla.
Los botones
: Borrar alto de fila y Borrar ancho de columna, se pueden utilizar para
borrar todos los valores de altura de fila y anchura de columna de la tabla.
Los botones
: Convertir ancho de tabla a píxeles se pueden utilizar para convertir
la anchura de la tabla expresada en forma de porcentaje de la ventana del explorador a su anchura
actual expresada en píxeles y viceversa.
Borde, especifica la anchura del borde de la tabla en píxeles. Para ver los límites de celda y tabla
cuando el borde está definido como 0, elegir Menú Ver > Bordes de tabla.
Borde claro y Borde oscuro para seleccionar los colores de borde que tienen un efecto de
resaltado y sombra, respectivamente, para dar apariencia tridimensional al borde.
Borde permite seleccionar un color de borde para toda la tabla. (en el ejemplo de arriba
el borde:2 y el color negro de Fnd:#000000, se "come" al borde oscuro: #333300 y al borde
claro: #3399CC que apenas se distingue.)
Fnd establece la imagen de fondo (campo de arriba) o el color de fondo (campo de abajo) de
la tabla. (en el ejemplo de arriba se ha optado por que el color de fondo de la tabla se
negro: Fnd:#000000, pero que cada celda tenga su propio color)
Para seleccionar opciones de diseño de celda:
Rell. celda, especifica el número de píxeles que habrá entre el contenido de la celda y el límite de
ésta.
Esp. celda, especifica el número de píxeles que debe haber entre las celdas de la tabla.
Para el color de fondo, seleccionar cada celda y en Fnd, indicar el color deseado.
Para editar el ancho de las columnas:
Colocar el cursor del ratón en medio de las dos columnas (el cursor cambia a una forma de dos
flechas opuestas) en ese momento pulsar el botón izquierdo del ratón y, sin soltarlo,
Desplazarlo hacia la izquierda hasta que la columna de la izquierda quede a la altura de la franja de
diseño del fondo.
Soltar el botón izquierdo del ratón.
Para que el borde de la tabla no se vea en el navegador
Seleccionar pulsando dentro de la tabla con el botón derecho del ratón, y en el menú
emergente elegir la opciónTabla>Seleccionar Tabla),
En la paleta Propiedades Tabla escoger la opción Borde y cambiar el valor que aparece
predeterminado por el valor 0, y dar a Intro; de esta manera se logra que la tabla sea invisible
cuando la veamos en el navegador.
Descargar