Instalación y uso de JCoverage

Anuncio
Universidad de los Andes
Ingeniería de Sistemas y Computación
Instalación y uso de JCoverage
Elaborado por: David Fernando Méndez
Instalación de JCoverage
Proyecto Cupi3
Guía para la descarga e instalación del plugin de eclipse que permite la
evaluación del cubrimiento de pruebas unitarias.
Nota: Este tutorial está diseñado para el uso y la instalación de la herramienta en eclipse 3.3
Para instalar JCoverage siga los siguientes pasos:
1. Ingrese al gestor de actualizaciones de Eclipse mediante la ruta Help -> Software Updates ->
Find and Install.
2. Seleccione la opción “Search for new features to install”.
3. Agregue un nuevo sitio remoto al gestor de descargas.
4. La ruta del nuevo sitio remoto es http://eclipse.jcoverage.com. Luego, clic en OK.
5. Lo que sigue es seleccionar los ítems de descarga. En este caso, se seleccionan TODOS los
ítems que se encuentran dentro del nuevo sitio remoto. Se inicia la descarga mediante el
botón “FINISH”.
6. Resta aceptar todos los ítems correspondientes a licencia de software y esperar que finalice
la descarga del plugin.
Uso de JCoverage
Se explica paso a paso el uso de la herramienta.
Mediante el ejemplo del colegio web de la sección de tutoriales del proyecto Cupi2 se ilustra el uso
de JCoverage. El código fuente puede ser encontrado el siguiente sitio web:
http://xue.uniandes.edu.co/~s2701a25/isis2701/JSF_ColegioWeb.zip
Siga los siguientes pasos para el uso de JCoverage sobre la aplicación.
1. Descargue e importe en eclipse el proyecto.
2. Despliegue la vista de JCoverage, para esto use la ruta Window -> Show View -> Other.
Luego seleccione JCoverage -> Coverage Summary Tree View.
3. Ahora es necesario validar la licencia de JCoverage. Para esto haga clic derecho sobre el
proyecto y seleccione “Add/Remove JCoverage Nature”.
Llene el formulario con datos válidos.
En breve, recibirá un correo electrónico con el número de validación de licencia. Ingréselo y
haga clic en Finalizar.
Con esto, debe aparecer una nueva vista en el eclipse que se ve de la siguiente manera.
4. Finalmente se puede generar un reporte HTML con los resultados del análisis de pruebas.
Para generarlo se debe hacer clic derecho sobre el nombre del proyecto en la vista de
JCoverage.
Note que los resultados muestran que las pruebas unitarias prueban el 7% del código
implementado.
Note además, que los reportes HTML que genera JCoverage muestran exactamente cuáles son las
líneas de código que se están probando resaltándolas en amarillo.
Descargar
Fichas aleatorios
Explore flashcards