Manual de Access - Maristas Compostela

advertisement
Access
1ª Parte:
Una base de datos es una estructura donde se almacena una información relativa
a entidades del mundo real organizada de una forma lógica que permita un acceso
rápido a dicha información.
Un libro de recetas de cocina es una base de datos: el nombre del plato, los
ingredientes, tiempo de preparación, fotografía del plato terminado, valor calórico,
etc son datos organizados para que resulte fácil su búsqueda y consulta. La guía
telefónica es otra base de datos con informaciones como el nombre del usuario,
domicilio y número de teléfono. El registro de notas de un profesor es una base de
datos con abundantes datos de cada alumno, personales y académicos y que se
renueva y completa continuamente y es necesario consultar con mucha frecuencia
en distintos sentidos. El archivo de una biblioteca es otra base de datos muy
corriente con informaciones como el autor, título, editorial, nº de páginas, etc. Y,
por cierto, una biblioteca suele tener mas de un archivo: uno en que los libros
están ordenados y clasificados por títulos y otro por autores, como mínimo. Pero
también se puede facilitar la elección mediante una clasificación por géneros, por
ejemplo. De este modo nos podemos encontrar con que esta base de datos tiene
algunos inconvenientes:




Rigidez en la búsqueda: cada fichero tiene una organización determinada y
una forma de búsqueda concreta. Con la guía de teléfonos es muy fácil
encontrar el número de un abonado sabiendo su nombre. Pero resulta
complicado determinar todos los números de los abonados de una calle
concreta y casi imposible saber a que abonado pertenece un número dado.
Redundancia: Un mismo dato puede aparecer en diferentes ficheros
Difícil de actualizar: operación costosa especialmente cuando un mismo dato
está en distintos ficheros.
Presentación predeterminada de la información: cada ficha es como es y
contiene generalmente mas datos de los que necesitamos conocer en
muchos momentos.
Muchos de estos inconvenientes se solucionarían mediante un ordenador
convenientemente programado. Un programa adecuado para estos fines es lo que
en informática se llama un gestor de bases de datos.
Un gestor de base de datos es un programa informático que permite almacenar
datos, ordenarlos, clasificarlos y organizarlos para poder seleccionar aquellos que
nos interesen en un momento dado.
Un gestor de base de datos presenta claras ventajas frente a un fichero tradicional:





Almacena y sistematiza la información de forma automática
Permite guardar gran cantidad de información en muy poco espacio ya que
emplea un soporte electrónico
El acceso a la información es muy rápido y puede llevarse a cabo por
diferentes métodos
No hay redundancia (los datos se almacenan en un solo registro)
Los datos se pueden modificar en tiempo real y se pueden incluir nuevos
datos en cada registro sin modificar el soporte.
Así pues, una base de datos está constituida por la información propiamente dicha
y esos otros elementos destinados a presentar o acceder a la información de forma
seleccionada y concreta.
Los componentes o elementos de una base de datos son:






Las tablas: Es donde se guarda la información distribuida en filas y
columnas. Las columnas se llaman campos y son los que indican la
información que tendrá la base de datos sobre cada una de las entidades
almacenadas. Las filas se llaman registros y existe un registro por cada
entidad almacenada en la base de datos (son el equivalente a las fichas de
los ficheros tradicionales). En Excel también se trabajaba con tablas a veces,
y de hecho, Access puede importar tablas de Excel y Excel puede importar
tablas de Access.
Las consultas: son los elementos que nos permiten interrogar a la base de
datos sobre la información que contiene para, de esta forma, seleccionar
solo parte de ella y poder actuar sobre dicha información. En una consulta
podemos filtrar los datos para quedarnos solo con los que nos interesan en
un momento dado y podemos incluso juntar datos de varias tablas a la vez.
Por ejemplo en una guía telefónica podríamos seleccionar la información
relativa a los usuarios de una calle determinada, o los establecimientos
comerciales de un tipo concreto, etc.
Los formularios: Permiten ver en pantalla la información de una tabla de
una manera cómoda y modificarla. La vista de la tabla completa permite ver
mucha información de un solo vistazo, pero muy concentrada y,
normalmente no queremos ver tanta información a la vez sino solamente
aquella que nos interesa. Si esto lo presentamos en una pantalla elegante,
con botones de acceso a las distintas funciones y un tipo de letra que se lea
con comodidad o resalte lo que consideremos mas significativo,
trabajaremos de una forma mas eficaz y relajada.
Los informes: Imprimen la información de una tabla o de una consulta, de
modo que presentan generalmente mas de un registro y se les puede dotar
de una cabecera, pie de página, etc.
Las macros: son un conjunto de instrucciones consecutivas que se pueden
almacenar para realizar tareas repetitivas. Representan un ahorro de tiempo
considerable en la utilización de bases de datos complejas.
Los módulos: son programas o conjuntos de instrucciones en lenguaje
Visual Basic que permiten la posibilidad de realizar aplicaciones “a medida”
para empresas o usuarios expertos.
Existen dos categorías de bases de datos:


Planas: cuando organizan los datos en una sola tabla que incluye todos los
campos que se desea contemplar para cada registro.
Relacionales: cuando el número de Campos que se desea contemplar para
cada registro es muy grande y se organizan en varias tablas relacionadas
entre si y vinculadas unas con otras por un campo común.
Las prestaciones de cualquier base de datos se pueden resumir:





Permiten introducir y almacenar datos, recuperarlos y trabajar con ellos
Efectuar cálculos sobre los datos numéricos almacenados
Importar y exportar datos desde y hacia otros programas, elaborar
informes, formularios, consultas, etc y guardarlos para posterior uso o
imprimirlos en el momento.
Ordenar los datos incluidos. El orden se puede definir por cualquiera de los
campos contenidos y puede ser alfabético, numérico o por fechas,
dependiendo de la naturaleza de los datos. También puede ser ascendente o
descendente en relación con un concepto determinado.
Efectuar búsquedas de forma rápida y, si queremos, imprimir el resultado de
estas búsquedas.
En el mercado actual existen distintos gestores de bases de datos para usuarios
particulares o para pequeñas y medianas empresas (el primer programa
informático explotado comercialmente fue un gestor de base de datos) siendo los
mas conocidos:





Access: de la empresa Microsoft que por su facilidad de uso y rapidez de
consulta es el mas empleado actualmente. Está incluido como una parte de
la Suite Office y permite intercambiar información con el resto de programas
incluidos de una forma muy rápida y eficaz.
Approach: de la empresa Lotus
Parados 9: de Corel (sólo disponible en inglés)
FileMaker Pro: de Claris
Últimamente están adquiriendo cierta relevancia los gestores de base de
datos de código abierto y libre distribución como los incluidos en las suits
Open Office o Star Office.
Sea cual se el programa que se vaya a utilizar para diseñar y construir una base de
datos hay que reparar en dos aspectos fundamentales:


Conocer exactamente para que se quiere usar la base de datos y que
información se quiere incluir en cada uno de sus registros.
Definir el número de tablas que contendrá la base, el número de campos de
cada una y la forma de ordenación y relaciones entre las tablas.
Estos aspectos son importantes porque aunque se pueda modificar en cualquier
momento cualquiera de los componentes de la base, en el caso de una tabla, por
ejemplo, es mas sencillo variar la estructura si está vacía que si ya contiene datos.
En este último caso, si cambiamos un campo o lo eliminamos puede que al final
perdamos algún dato.
Vamos a comenzar con el caso de una base de datos plana (con una sola tabla). Al
arrancar el programa se abre una ventana vacia con los distintos menús:
Mediante el icono correspondiente o a través del menú de Archivo activamos la
opción Nuevo con lo que aparece una ventana o se despliega un menú, según la
versión usada, donde se nos presentan las distintas posibilidades de comenzar a
trabajar. Por ejemplo:
En esta pantalla se muestran las tres formas posibles de iniciar una base de datos:
 Base de datos en blanco
 A partir de un archivo existente
 A partir de una plantilla
A partir de un archivo existente consiste en modificar una base de datos que ya
tenemos y seguir manteniendo una copia de la que hemos partido.
A partir de una plantilla se ofrecen múltiples posibilidades para casos concretos:
Elegido el adecuado, un asistente nos guía en el proceso de creación de la base.
Si elegimos la opción de una base de datos en blanco, tenemos que empezar de
cero. Una vez seleccionada esta opción aparece una ventana donde nos pide que le
demos un nombre y que se guarde aun antes de iniciar el proceso de introducir
información:
La razón de esta manera de funcionar es porque Access guarda todos los elementos
de la base de datos en un único archivo con la extensión .MDB y como todos los
gestores de base de datos guarda inmediatamente el registro de una tabla que
estemos manipulando antes de pasar al siguiente. De esta manera se protege la
información para que no se pueda perder por un fallo eléctrico o del propio
ordenador. Con esto ya se ha creado la base de datos y hay que pasar a llenarla.
Una vez nombrada y creada la base de datos aparece la ventana que muestra las
distintas opciones y que, según la versión, puede tener distintos aspectos:
Elegimos Tablas y nos aparecen las opciones para crear una tabla que son tres: en
vista diseño, utilizando el asistente o introduciendo datos.
Elegiremos la opción “crear una tabla en vista diseño” seleccionando esta
opción y pulsando “nuevo” con lo que aparece una nueva ventana con las opciones
disponibles para crear la tabla:
Si elegimos la opción “Vista Diseño” se despliega una nueva ventana:
En la columna Nombre del campo introducimos el nombre descriptivo que le
damos a cada campo.
En la columna Tipo de datos, al colocar el cursor aparece a
la derecha una flecha que indica la presencia de un menú
desplegable.
Al desplegar dicho menú aparece:
Hasta 256 caracteres alfanuméricos
Hasta 65535 caracteres alfanuméricos
Campo numérico que aumenta su valor de
uno en uno según se añaden registros
Archivo generado por otra
aplicación de Windows
(P.Ej. un gráfico, foto, etc.)
Campo lógico con solo dos
valores posibles: verdadero
(si, 1) o falso (no, 0 ó nada)
Una dirección de Internet o de
Nuestro disco duro o red
Donde se muestran los distintos tipos de datos admitidos. Elegimos uno y si no lo
hacemos Access entiende por defecto el tipo Texto.
La columna Descripción es opcional y nos permite introducir el contenido del
campo.
En la parte inferior izquierda de esta ventana de tres columnas que estamos
estudiando está el panel de propiedades de los campos desde el que podemos
modificar o introducir ciertas características de los mismos.
(Algunos tipos de campos puede que no tengan todas las propiedades señaladas en
la ilustración anterior)
El Tamaño permite modificar dentro de los límites validos el valor por defecto que
da el programa.
El Formato tiene especial interés con datos numéricos, de moneda, de fecha o
lógicos y al hacer clic en el mismo se despliega un menú con las distintas
posibilidades disponibles, del que elegimos la que nos interese. Por ejemplo, en el
caso del tipo de fecha y hora se despliega el cuadro siguiente:
Mediante la máscara de entrada podemos obligar al usuario a ceñirse a un
número determinado de caracteres o a un tipo específico de dato.
Si en Requerido activamos la opción “Si”, el campo nunca podrá estar vacío.
Las restantes propiedades no las describimos de momento y dejamos su estudio
para un nivel mas avanzado del presente
Una vez finalizada la tabla se accede al menú de Archivo y dentro de él a la opción
Guardar y cuando aparezca la ventana de diálogo se escribe el nombre de la tabla
y se pulsa Aceptar.
En ese momento Access advierte:
Si elegimos No, la tabla no tendrá ninguna clave principal.
Si elegimos Si, Access crea un campo Autonumérico con el nombre “Id” que será
la clave principal. Si se desea cambiar esta clave, es posible borrar este campo y
asignarle a otro el carácter de clave principal. El campo que tenga este carácter
queda marcado con una pequeña llave a la izquierda del nombre.
A partir de este momento la tabla está preparada para introducirle información.
Para introducir la información hemos de tener la tabla en el modo Vista Hoja de
Datos que se selecciona desde el menú Ver de la barra principal.
Desde esta pantalla y desde el menú Formato se puede configurar el aspecto de la
tabla cambiando el tipo y tamaño de letra, color de fondo y de la cuadrícula, etc. El
ancho de columnas se puede cambiar de la misma forma que se hacía en Excel y en
las tablas de Word (Arrastrando desde la cabecera).
En la parte inferior aparece un contador que nos indica en que registro estamos,
cuantos registros tenemos y nos permite navegar por la tabla. Incluso es posible
seleccionar un registro y mediante el botón
eliminarlo totalmente.
Así mismo, se pueden renombrar los campos e incluso ordenar la tabla. Para ello,
ponemos el cursor en alguna casilla del campo que queremos tomar como base de
la ordenación y mediante los botones:
Se ordena en modo ascendente o descendente.
Se puede igualmente cambiar el orden de los campos sin mas que seleccionar
desde la cabecera y arrastrar a la posición deseada.
Para desplazarnos de un campo a otro podemos:
-
Hacer doble clic en el interior de la celda a la que queremos ir
Utilizar la tecla Intro para cambiar de línea
Emplear el tabulador para saltar de campo a campo
Si necesitamos buscar un registro procedemos de la manera siguiente:
-
Accedemos al menú Edición y activamos la opción Buscar
Cuando aparece la ventana de diálogo, escribimos el texto que deseamos
buscar en la ventana Buscar y aceptamos.
Es conveniente que practiques todo lo tratado hasta el momento
antes de seguir adelante y para ello crea una base de datos e intenta
crear varias tablas con distinta estructura, introduce registros, borra
alguno, ordena según distintos criterios, cambia el aspecto de las
tablas, elimina alguna tabla, etc.
Conviene que no pases a la segunda parte antes de entender lo que
hemos tratado en esta primera.
2ª parte
CONSULTAS
Los gestores de bases de datos permiten hacer consultas a partir de las tablas que
contienen.
Cuando trabajamos con una base de datos plana, únicamente es posible la consulta
de selección. Para realizarla procedemos de la forma siguiente:
Dentro de la ventana principal de la base de datos seleccionamos Consultas
Y se ofrece la posibilidad de hacer la consulta libremente o guiados por un
asistente. Contemplamos el caso de Crear una consulta en vista Diseño, y una
vez seleccionada la opción picamos en Nuevo:
Elegimos Vista Diseño y se abre la ventana de consulta y sobre ella otra de
diálogo que nos permite elegir la tabla en la que queremos hacer la consulta.
Seleccionamos la tabla con Agregar y cerramos la ventana mediante
Con lo que nos queda la ventana de consulta:
En la parte superior muestra los campos que componen la tabla y en la inferior los
posibles criterios que podemos aplicar.




Para introducir un campo en la casilla Campo basta hacer un doble click en
su nombre que aparece en la parte superior. En la casilla Tabla aparecerá el
nombre de aquella de la que procede el campo seleccionado.
En la casilla Orden se establece el orden de aparición de los campos
(ascendente o descendente o ninguno). Si no se establece alguno, se
presentará en el orden en que aparecen en la tabla.
En la casilla Mostrar aparece un cuadrado sobre cada campo que sirve para
seleccionar sobre el mismo el campo correspondiente. Si no se señala este
cuadradito, el campo no se mostrará.
En la casilla Criterios se introduce la condición que debe cumplir un campo
para que el registro aparezca en la consulta.
Una vez cumplimentadas las casillas necesarias podemos cerrar la consulta y
asignarle un nombre y el programa la guarda.
Si se desea ver el resultado de la consulta elaborada, basta hacer doble clic sobre
su nombre y aparecerá en Vista hoja de datos. Una vez terminada la consulta se
cierra en la forma habitual.
FORMULARIOS
Con un formulario accedemos a los datos de las tablas de una manera mas
cómoda y atractiva y también podemos introducir datos de una forma sencilla.
El autoformulario es la manera mas rápida de crear un formulario sencillo que solo
implique una tabla. Los pasos a seguir son los siguientes:
- Seleccionar la tabla de la que se quiere hacer un autoformulario
- En el menú Insertar, elegir Autoformulario
Con ello aparece el formulario de la forma siguiente:
Si es de nuestro agrado podemos guardarlo desde el menú Archivo de la misma
forma que guardamos cualquier archivo.
Puede que queramos crear un formulario distinto del anterior y podemos hacerlo a
partir del asistente o a partir de cero (en Vista Diseño). Veamos el último caso.
Seleccionamos: Formulario – Crear formulario en vista Diseño – Nuevo y en la
ventana que se abre marcamos Vista Diseño y elegimos la tabla de donde
proceden los datos y a continuación Aceptar. Con ello aparece:
Para incluir campos en el formulario arrastramos desde la ventana donde aparecen
los campos hasta el área de trabajo y configuramos el formulario a nuestra
voluntad. Al arrastrar los campos aparece el campo y la etiqueta que lo identifica:
Campo
Etiqueta
Si se quiere acercar o mover la etiqueta o el campo se hace clic en el cuadrado
grueso de la esquina superior izquierda del elemento que se quiere mover y se
arrastra hasta la posición deseada.
Si se quiere eliminar alguna etiqueta se selecciona haciendo clic sobre ella y se
pulsa sobre la tecla Suprimir.
Desde el cuadro de herramientas se pueden incorporar si se desea cualquiera de las
disponibles de la misma forma.
Para apreciar mejor el trabajo que se está realizando se puede alternar entre la
Vista Diseño y la Vista Formulario a la que se accede desde el menú Ver de la barra
principal.
Cuando el formulario tenga el aspecto deseado lo podemos guardar de la forma
habitual dándole el nombre correspondiente.
INFORMES
Los informes sirven para presentar los datos de una base de datos de forma
impresa.
El caso mas sencillo es el autoinforme, que se genera de la misma forma que el
autoformulario: Tabla – (elegir una tabla) – Insertar – Autoinforme
Generalmente no presenta un aspecto muy atractivo, por lo que es conveniente
programar el informe a nuestro gusto particular. El modo mas sencillo para ello es
utilizando el asistente para informes.
Para ello activamos sucesivamente: Informe – Crear un informe utilizando el
asistente – Nuevo y en la nueva ventana que aparece seleccionamos la tabla o
consulta de la que proceden los datos y Asistente para Informes y al aceptar
aparece:
Donde vamos seleccionando los campos que queremos incluir en el informe
haciendo clic dos veces sobre cada uno de ellos y cuando estén todos los que
queremos incluir pulsamos Siguiente. Contestamos la pregunta que nos formula el
asistente (De ella depende el aspecto que presentará el informe) y pulsamos
Siguiente
Completamos la Ventana y Siguiente.
Aparece una nueva ventana que
completamos eligiendo entre las opciones presentes y pulsamos de nuevo
Siguiente. En la nueva ventana se pide elegir el estilo entre los dados:
Es aconsejable probarlos todos para ver cual es el de nuestro agrado y cuando se
haya elegido pulsar Siguiente. Nos pide entonces que le demos un nombre al
informe y se puede elegir previsualizar el resultado, para lo que pulsamos Finalizar
y se nos presenta el informe generado:
Al cerrar la ventana de presentación preliminar el informe se guarda con el nombre
dado previamente.
3ª parte
BASES DE DATOS RELACIONALES
Las bases de datos relacionales son aquellas en las que la información está
guardada en varias tablas distintas que se relacionan entre si de alguna manera.
Al crear una base de datos relacional hemos de tener presente qué información
queremos que contenga, cómo la podemos distribuir en tablas, qué campos debe
incluir cada una y cómo se pueden relacionar entre ellas.
De Cara al establecimiento de relaciones es importante en cada tabla el campo
clave que sirve para identificar de forma irrefutable cada registro. Por ello ha de
tener dos características:
- Ser único (sin duplicados)
- No puede tener un valor nulo
Access ordena internamente cada tabla por el campo clave. De ahí su importancia.
Al crear una tabla y guardarla, si no hemos marcado un campo clave, el programa
nos lo recuerda y nos da la opción de crear él mismo la clave. Si así fuera, crearía
un campo autonumérico identificado como Id.
En cuanto a las relaciones entre tablas, pueden ser de diversos tipos:


1:1 : que quiere decir que cada elemento de la primera tabla se relaciona
solo con uno de la segunda y al contrario también uno de la segunda con
uno de la primera únicamente.
EQUIPO
ENTRENADOR
(Cada equipo tiene un solo entrenador y cada entrenador entrena solo a un
equipo)
1: N : Cuando cada elemento de la primera tabla se relaciona solo con uno
de la segunda, pero sin embargo cada uno de la segunda se puede
relacionar con varios de la primera.
JUGADOR
EQUIPO
(Cada jugador solo juega en un equipo, pero cada equipo tiene varios
jugadores)

N:N : Cuando cada elemento de cada tabla se puede relacionar con varios
de la otra.
PELICULAS
ACTORES
(en una película interviene varios actores y un actor puede intervenir en
varias películas)
EJEMPLO DE UNA BASE DE DATOS RELACIONAL:
Supóngase que queremos construir una base de datos en que estén contenidas
informaciones relativas a jugadores, equipos y entrenadores en la temporada
actual.
Podríamos organizarla como se indica en el esquema siguiente:
 Id
JUGADOR
PUESTO
EQUIPO
NACIONALIDAD
EDAD
JUGADORES
Juegan
1:N
 Id
EQUIPO
CIUDAD
ENTRENADOR
PRESUPUESTO
EQUIPOS
Entrenan
ENTRENADORE
S
1:1
 ENTRENADOR
EQUIPO
NACIONALIDAD
Y, una vez creadas las tablas, con los campos indicados y como ya sabemos, hay
que crear las relaciones. Para ello vamos al menú Herramientas – Relaciones y
nos aparece la ventana:
A partir de la cual agregamos todas las tablas y establecemos las relaciones
picando en el campo de una tabla y arrastrando sobre el campo de la otra que
queremos relacionar. El especto final sería:
Y a partir de este momento ya podemos introducir la información y generar
informes, consultas y formularios.
Para crear consultas, informes o formularios se sigue el mismo procedimiento ya
indicado pero como ahora hay mas de una tabla habrá que indicar la procedencia
de cada campo que se incluya y las relaciones entre tablas.
TECNOLOGÍA OLE
La tecnología OLE (Object Linking and Embedding) es un sistema de compartir
ficheros entre aplicaciones que nos permitirá transferir información de una a otra. A
través de esta tecnología podremos, por ejemplo, insertar un objeto gráfico en un
formulario de Access como si fuera un campo más. Estos objetos pueden insertarse
de dos formas:


Incrustación: el objeto es almacenado en la base de datos, pero si el
objeto original sufre algún cambio, en la base de datos no se reflejará el
cambio.
Vinculación: el objeto es almacenado igual en la base datos, pero se
establece un vínculo con el archivo original de forma que si modificamos el
objeto desde el formulario, los cambios afectarán al archivo original.
Tanto si incrustamos como si vinculamos, el objeto debe crearse en el formulario
mediante el control llamado marco de objeto. Podemos utilizar estas opciones
para insertar una imagen de una persona como si fuese un campo más de la base
de datos. Existen dos tipos de marcos:


Marco de objeto independiente: para incluir objetos que no están
almacenados en una tabla. Por ejemplo, un logotipo.
Marco de objeto dependiente: para incluir gráficos y objetos OLE que
están almacenados en la tabla como un campo más.
A continuación te mostramos algunos consejos para saber cuando utilizar cada
uno de los diferentes tipos de marcos:
Tipo de marco
Tipo de enlace
Se usa...
Incrustación
Para añadir un objeto que forme parte de un
formulario, pero que no dependa de ningún
campo y que sea independiente de su original.
Por ejemplo, un gráfico en un informe
Objeto
independiente
Vinculación
Objeto que forma parte del formulario pero no
depende de ningún campo. Por ejemplo, una
hoja de cálculo que se actualize cada vez que
se modifique el archivo original
Objeto
dependiente
Incrustación
Gráfico en campos de una tabla. Por ejemplo,
una imagen de una persona que puedan
modificarse y visualizarse desde el formulario
Objeto
dependiente
Vinculación
Objetos en un campo de la tabla, pero que se
mantienen en archivos separados.
Objeto
independiente
Existen dos botones en el modo de vista de Diseño de formulario para crear este
tipo de controles: Marco de objeto dependiente y Marco de objeto
independiente. Ambos botones están situados en las barras de herramientas.
4ª parte
COMPACTAR UNA BASE DE DATOS
Si borras, modificas y crear tablas a menudo, la base de datos puede
fragmentarse, lo que provoca un uso deficiente del espacio en disco. Al compactar
la base de datos, se hace una copia de la misma y se reorganiza el espacio que
ocupa en el disco. Es algo parecido a la acción del comando Defrag
Para compactar la base de datos actual:

Accede Herramientas - Utilidades de la base de datos - Compactar
base de datos.
Para compactar una base de datos que no está abierta en Access
1. Cierra la base de datos actual.
2. Accede Herramientas - Utilidades de la base de datos - Compactar base
de datos.
3. En el cuadro de diálogo Base de datos a compactar, especifica la base de
datos que deseas compactar y haz clic en Compactar.
4. En el cuadro de diálogo Compactar la base de datos en, especifique el
nombre, unidad y carpeta donde desea almacenar la base de datos compactada.
5. Haz clic en Guardar.
Si utilizas el mismo nombre, unidad y directorio y si la base de datos se compacta
con éxito, Access reemplazará el archivo de origen por la versión compactada.
Importante:


Si eliminas registros del final de una tabla que contiene un campo
Autonumérico, cuando compactes la base de datos, Access te dará al
próximo campo Autonumérico el valor del último contador sin borrar, más
1.
La compactación de una base de datos de Access de una versión previa no la
convierte al formato de Access 97.
Crear una réplica de la base de datos
Imaginemos que varios usuarios situados en distintos lugares van a utilizar la base
de datos. Podemos crear lo que se llama una Réplica de la base de datos y
posteriormente unir los datos introducidos desde todas las réplicas que se hagan.
Cada réplica es miembro de un conjunto de réplicas que se pueden sincronizar
con otras réplicas del mismo grupo, es decir, los cambios realizados en una réplica
se aplican a las otras réplicas y al Diseño principal o base de datos original.
Veamos cómo crear una réplica de nuestra base de datos:


Abre la base de datos
Accede a Herramientas – Réplica – Crear réplica. Aparecerá un mensaje
de aviso:

Contesta afirmativamente.
Se mostrará otro mensaje que nos avisa que la base de datos original se
convertirá en el Diseño principal. Además se indica el nombre con el que se
guardará la réplica y la carpeta donde se almacenará ésta.


Pulsa en Sí
Acepta el nombre que ofrece Access
Al aceptar, Access crea la réplica y nos muestra un mensaje que la única copia
donde podremos modificar la estructura original será la copia original de la base de
datos.
Sin embargo, los datos podremos editarlos en cualquiera de las réplicas que
hayamos realizado.

Acepta el último cuadro de diálogo que ha aparecido.
Ahora fíjate que en los nombres de las tablas aparece un nuevo icono y en el
título aparece la palabra Diseño principal.



Añade un nuevo cliente en la base de datos principal para probar la
sincronización entre bases de datos.
Accede a Herramientas – Réplica – Sincronizar ahora
Acepta el cuadro de diálogo que aparece.
Por último, Access avisa que no serán visibles los cambios hasta que cerremos y
abramos la tabla.


Acepta
Abre la tabla y observa los cambios.
Hay que señalar que en el proceso de sincronización de datos entre réplicas
primero se actualizan los cambios en el diseño y después en los datos. El
intercambio entre dos réplicas puede ser en los dos sentidos, es decir, de la
principal a la réplica o viceversa.
Por último, después de sincronizar dos réplicas, es conveniente revisar la base
de datos en busca de posibles errores desde la opción Herramientas – Réplica –
Resolver conflictos.
HACER UNA COPIA
Los datos que tenemos en una base de datos pueden llegar a ser muy valiosos. De
hecho, cualquier accidente o pérdida de datos, aparte de llegar a suponer una
pérdida económica considerable, puede llegar a "cabrearnos" bastante después de
tantas horas de trabajo.
La pérdida de la información puede prevenirse de varias formas:




Realiza copias de seguridad de los archivos MDB con frecuencia.
Haz copias de las tablas. A veces, una consulta de actualización
puede desembocar en resultados catastróficos.
Crea réplicas si es necesario.
Protege con contraseñas la base de datos.
Nunca te fíes de un ordenador. Es una máquina, y como tal, falla. El día menos
pensado te quedas sin un fichero, se introduce un virus, borras accidentalmente
información o cualquier otra situación similar y es cuando nos acordamos de porqué
no hemos hecho una copia en disquete de nuestros archivos.
Es muy importante crearse copias de todo lo que consideremos importante. Es
pues, necesario, crearse una copia de alguna tabla dentro de la propia base de
datos. Ten en cuenta que en Access, hay opciones un poco... digamos... delicadas,
que pueden hacer que los datos de la base cambien por completo. Si tienes una
copia, no hay problema: se recupera y ¡listo! Si no tenías copia… el desastre es
irremediable.
Para hacer una copia de una tabla, debes tener cerrada la tabla. Desde la pantalla
principal:
-
-
Selecciona la tabla
Pulsa el botón Copiar de la barra de herramientas, o bien Edición Copiar
Pulsa el botón Pegar de la barra de herramientas, o bien Edición –
Pegar
Cuando Access te pida un nuevo nombre, escribe el que creas oportuno.
Al aceptar aparece:
Y al Aceptar de nuevo queda disponible la copia.
Igual se puede proceder con consultas, informes y formularios.
Access dispone de dos sistemas para asegurar la información de una base de datos:
Contraseña: el acceso a la base de datos por completo está restringido por
contraseña. Hay que tener en cuenta que, aunque la contraseña está encriptada
para que no pueda leerse mientras se escribe, una vez abierta podemos acceder a
todos los objetos, incluso anular o cambiar la contraseña.
No utilices una contraseña de base de datos si vas a replicar una base de datos. Las
bases de datos replicadas no pueden sincronizarse si se definen contraseñas para
ellas
Para establecer una contraseña debe abrirse la base de datos en Modo exclusivo:
Una vez abierta:
Y en la ventana que emerge se escribe y se confirma la contraseña deseada y se
Acepta. Al cerrar la Base de datos y querer abrirla de nuevo nos pide la contraseña
y sin ella resulta imposible abrir la base.
Abriendo la base de datos en Modo Exclusivo es posible anular o cambiar la
contraseña siempre que se desee.
Seguridad a nivel de usuario: se limita el acceso para cada usuario. Éste tendrá
acceso sólo a determinadas partes de la base de datos.
- Cierra cualquier base de datos que tengas abierta.
- Accede a Archivo - Abrir para abrir una base de datos.
- Selecciona cualquier base de datos que tengas y activa el botón Exclusivo
- Ábrela
Hemos utilizado la opción Exclusivo porque si estamos trabajando en red,
ningún otro usuario podrá acceder a la base de datos.
- Accede a Herramientas - Seguridad - Establecer contraseña para la base
de datos.
- Escribe en las dos casillas la misma contraseña. Una cualquiera y acepta.
Si no hubiésemos abierto la base de datos en modo Exclusivo, Access nos
hubiese mostrado un mensaje indicando que debemos abrirla en este modo, y nos
impediría asignar una contraseña.
- Cierra la base de datos.
-Vuelve a abrirla. (Access pregunta por la contraseña:)
Si no la introducimos correctamente, no podremos acceder a la base de datos.
- Prueba a introducir cualquier carácter que no coincida con la contraseña
asignada.
- Prueba a introducir la contraseña correcta.
Para eliminar la contraseña bastará con acceder a la opción Herramientas Seguridad - Anular contraseña establecida para la base de datos1.
También podemos proteger la base de datos contra cambios en el diseño del
formulario, informes y módulos haciendo una copia de la base de datos en formato
MDE. Para ello:
-
Accede a Herramientas - Utilidades de la base de datos - Crear archivo MDE.
Elige una carpeta y acepta el nombre que propone Access.
Cierra la base de datos.
Pulsa en Abrir.
Abre la lista desplegable Tipo de archivo y elige Archivos MDE
- Abre la base de datos que hemos creado en formato MDE.
- Intenta acceder al modo Diseño de cualquier formulario.
Descargar