PROTEL DXP 2004 - Tutorial
Crear un proyecto
Un proyecto guarda los links a todos los documentos y las configuraciones relacionadas con
el diseño.
1 - Crear un nuevo proyecto desde el menú File/New/PCB Project
Se abre el panel de proyectos.
1
PROTEL DXP 2004 - Tutorial
2 - Cambiar el nombre del proyecto desde el menú File/Save Proyect As por “MiProyecto”
2
PROTEL DXP 2004 - Tutorial
Crear un esquemático
1 - Crear un esquemático desde el menú File/New/Schematic.
Automáticamente se agrega a nuestro proyecto, es decir, el proyecto guarda un link al
esquemático que creamos.
Al crear el esquemático aparecen las barras de tareas con las herramientas necesarias para
trabajar en el diseño del mismo.
2 - Cerrar la ventana Sheet la cual no utilizaremos.
3 - Cambar el nombre desde el menú File/Save as por “MiEsquematico”.
4 - Luego desde el menú Desing/Document Options... configurar las propiedades del
documento como se muestra a continuación.
3
PROTEL DXP 2004 - Tutorial
5 - Agregar librerías al proyecto
Para comenzar a trabajar en el esquemático se deben agregar al proyecto las librerías de
componentes que se utilizarán.
Al iniciar protel ya se encuentran cargadas un conjunto de librerías pero es probable que se
necesiten componentes que no se encuentren en éstas.
a) Hacer click en el Tab System/Libraries situado en el margen inferior derecho de la
pantalla.
Se abre el panel de librerías.
4
PROTEL DXP 2004 - Tutorial
b) Con el botón Libraries... se accede al menú que permite agregar librerías a nuestro
proyecto.
5
PROTEL DXP 2004 - Tutorial
c) Con el botón Add Library... acceder al explorador para buscar las librerías a agregar.
De esta forma al abrir el proyecto se cargarán las librerías que se hayan agregado al mismo.
Para tener cargadas en todos los proyectos (por default) librerías se deben “instalar”
accediendo a esta utilidad a través de la solapa Installed.
Las librerías agregadas al proyecto a instaladas pueden quitarse con el botón “Remove”.
6) Agregar componentes al esquemático.
Seleccionar el componente de la lista del panel Libraries haciendo doble click sobre el
nombre del componente o con el botón de la derecha Place xxxx.
Una vez seleccionado arrastrarlo a la página del esquemático y soltarlo con el botón
izquierdo del mouse (con el botón derecho se deselecciona).
Añadir al esquemático un led, un conector de tres pines, dos resistencias, un transistor NPN,
dos Ground Power Port y dos VCC Power Port.
6
PROTEL DXP 2004 - Tutorial
7) Reordenar los componentes
Además de moverlos se necesitará rotarlos, reflejarlos, etc. Para esto se accede a las
propiedades de los mismos presionando el botón derecho del mouse sobre el componente y
seleccionando Properties del menú.
7
PROTEL DXP 2004 - Tutorial
8) Unir eléctricamente los componentes.
Utilizar la herramienta place wire de la barra de tareas.
8
PROTEL DXP 2004 - Tutorial
9) Asignar valores a los componentes
Editar el valor de los componentes (Por ejemplo 10K y 470 para las resistencias) desde las
propiedades de los mismos o haciendo doble click sobre la etiqueta que queremos cambiar.
La pantalla que se abre cuando editamos directamente una etiqueta es la siguiente:
10) Renombrar los componentes.
Los componentes tienen un nombre (designator) por defecto. Por ejemplo R? en el caso de
las resistencias. Al momento de compilar el proyecto (punto 11) aparecerá un error si dos
componentes tienen el mismo nombre.
Hay dos formas de renombrar los componentes:
Manual
Editar las propiedades de cada uno de los componentes y asignarles nombres distintos.
Automática
Utilizar la herramienta annotate del menú Tools.
9
PROTEL DXP 2004 - Tutorial
Pasos a seguir:
a) Elegir la Schematic Annotation Configuration.
b) Clickear “Reset Designators”. Los pasos a,b,c y d son para cuando se renombraron
los componentes y se desee realizar nuevamente. En caso contrario no producirá
ningún cambio y pueden omitirse.
c) Clickear “Accept Changes (Create ECO). Se abre una nueva ventana. Ejecutar
“Validate Changes”, “Execute Changes” y por último “Close”.
10
PROTEL DXP 2004 - Tutorial
d) Clickear “Close” de la pantalla annotate para que se actualicen los cambios en el
esquemático.
e) Abrir nuevamente la herramienta annotate del menú Tools.
f) Clickear “Update Changes List”.
g) Clickear “Accept Changes (Create ECO). Se abre una nueva ventana. Ejecutar
“Validate Changes”, “Execute Changes” y por último “Close”.
h) Clickear “Close” de la pantalla annotate para que se actualicen los cambios en el
esquemático.
11
PROTEL DXP 2004 - Tutorial
11 – Compilar el esquemático
Desde el menú Proyect/Compile Document xxxx.SCHDOC.
Esta herramienta verifica que no hay violaciones a las reglas de diseño y en caso de haberlas
muestra un mensaje indicando los errores.
Por ejemplo si dos componentes tiene el mismo nombre muestra el siguiente mensaje:
12
PROTEL DXP 2004 - Tutorial
Accesos rápidos en el diseño de esquemáticos
Pug / Pg Down: Zoom
Ctrl. + rueda del mouse: Zoom
Right-Click presionado: Desplaza la página
Tab: Permite acceder a las propiedades del componente seleccionado y cuando se lo está
posicionando.
X (mientras se posiciona un componente): Refleja en el eje X
Y (mientras se posiciona un componente): Refleja en el eje Y
SpaceBar: Rota el componente seleccionado mientras se mantiene el botón izquierdo
presionado
Ctrl + Left-Click presionado: Permite mover un componente manteniendo las conexiones
13
PROTEL DXP 2004 - Tutorial
Crear un PCB
Antes de transferir el circuito del esquemático al PCB se debe crear un PCB en blanco con
al menos una línea que delimite la placa (board outline).
La manera más fácil de crear un PCB en DXP es usando el PCB Wizard.
1 - Crear un nuevo PCB haciendo clic en “PCB Borard Wizard” del menú “New From
Template” del panel “File”
Aparece la siguiente pantalla
Hacer click en “Next”
a) Elegir el sistema de unidades a utilizar.
Imperial: para trabajar en milésimas de pulgadas.
Metric: para trabajar en milímetros.
Seleccionar Metric y pasar a la siguiente pantalla con “Next”.
14
PROTEL DXP 2004 - Tutorial
b) Definir el tamaño de la placa. Seleccionar “Custom” para definir un valor personalizado.
Pasar a la siguiente pantalla con “Next”.
c) Configurar el tamaño y características de la placa.
Pasar a la siguiente pantalla con “Next”.
15
PROTEL DXP 2004 - Tutorial
d) Definir la cantidad de caras de nuestra placa “Signal Layers” (minimo dos) y la cantidad
de planos (de masa , por ejemplo) que utilizaremos, en este caso ninguno.
Pasar a la siguiente pantalla con “Next”.
e) Definir el tipo de vias a utilizar en el diseño. En este ejemplo se utilizará “Thruhole Vias
only”.
Pasar a la siguiente pantalla con “Next”.
16
PROTEL DXP 2004 - Tutorial
f) Definir el tipo de componentes a utilizar, montaje superficial o Through-hole y cuantas
pistas se permitirá que pasen entre “patas” de integrados.
Pasar a la siguiente pantalla con “Next”.
g) Definir el ancho mínimo de las pistas, la separación mínima entre pistas , el tamaño
mínimo de las vías y el mínimo diámetro de las perforaciones.
Pasar a la siguiente pantalla con “Next”.
17
PROTEL DXP 2004 - Tutorial
h) Hacer click en “Finish” para terminar de crear la nueva placa.
i) Vista de la placa creada
La parte negra corresponde al tamaño de placa definido (100mm x 100mm).
18
PROTEL DXP 2004 - Tutorial
2) Configurar la página de trabajo desde el menú Desing/BoardOption...
19
PROTEL DXP 2004 - Tutorial
3) Guardar el PCB con el nombre “MiPCB” seleccionando el menú File/Save As...
4) Agregar el PCB al proyecto.
El documento se guarda como Free Document, es decir que no pertenece al proyecto. Para
agregarlo presionar el botón derecho del Mouse sobre el archivo del proyecto y seleccionar
Add Exixting to Proyect...
En el panel Projects puede observarse que el PCB la está incluido en el proyecto.
20
PROTEL DXP 2004 - Tutorial
5) Transferir la información del esquemático al PCB.
Abrir el Esquemático y seleccionar el menú Desing/UpdatePCB Document
Se muestra la siguiente pantalla
21
PROTEL DXP 2004 - Tutorial
Hacer clic en “Validate Changes”. Si todos los cambios son correctos aparecen tildes verdes
al lado de cada uno. Si los cambios no son válidos cerrar el cuadro y verificar en el panel
“Messages” los errores y corregirlos.
Clickear Execute Changes y luego Close.
6) Configurar los Layers
Acceder al menú Desing/Board Layers & Colors…
En esta ventana se puede configurar las propiedades de los distintos Layers, color, visible,
bloqueado, etc. .
7) Ordenar los componentes
22
PROTEL DXP 2004 - Tutorial
Para editar un componente hacer doble clic sobre el mismo. Se abre la ventana de
propiedades del mismo. Por ejemplo cambiar el Footprint de la resistencias por AXIAL -0.3
8) Actualizar los cambios en el Esquemático.
Si se realiza un cambio en el PCB , por ejemplo un footprint, se puede actualizar el
Esquemático para que refleje dichos cambios a través del menú Desing/ UpdateSchematics
23
PROTEL DXP 2004 - Tutorial
9) Ruteo de la placa
Manual
Para rutear en forma manual utilizar las herramientas de la barra de tareas tales como
“Interactively Route Connections”.
Cuando se está dibujando una pista u otro objeto presionando TAB se accede a la pantalla de
propiedades del mismo.
Automático
a) Configurar las reglas de ruteo seleccionando el menú Design/Rules...
Configurar el ancho de pista de 1mm
24
PROTEL DXP 2004 - Tutorial
Configurar los layers de manera de hacer la placa simple faz.
b) Ejecutar el Ruteo Automático seleccionando el menú AutoRoute/All y hacer click en
“Route All”.
25
PROTEL DXP 2004 - Tutorial
Circuito ruteado:
Para deshacer un ruteo seleccionar el menú Tools/Un-Route/All
26
PROTEL DXP 2004 - Tutorial
Panel PCB
El panel “PCB” permite buscar un componente , net, rules, etc. , pudiendo editarlo,
resaltarlo, etc.
Con el botón clear se borra cualquier máscara que se haya activado. Se entiende por máscara
tener resaltado los componentes, rutas, etc. que se han seleccionado y el resto ocultos o
dibujados mas claros.
Con la opción Mask level se selecciona el nivel de la máscara, es decir, con que intensidad
se dibujarán los componentes no seleccionados.
27
PROTEL DXP 2004 - Tutorial
Accesos rápidos en el diseño de PCBs
Pug / Pg Down: Zoom
Ctrl. + rueda del mouse: Zoom
Right-Click presionado: Desplaza la página
Tab: Permite acceder a las propiedades del componente seleccionado y cuando se lo está
posicionando.
SpaceBar: Rota el componente seleccionado mientras se mantiene el botón izquierdo
presionado
28
Descargar

Crear un nuevo proyecto

Clima social en el aula

Clima social en el aula

MaestrosEducaciónAlumnosEntornoPedagogíaContenidosTareasEscuelaComportamientoAdministración educativaAprendizajeEnseñanza

Tutoría y orientación

Tutoría y orientación

EducaciónAlumnosJuventudProfesoresPedagogíaProgramasAdolescenciaConsulta triádicaServiciosModelo clínicoPersonalidad