Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
Introducción a la GUI de Unity3D
1. Objetivos
Este tema es lo primero que debes leer si es la primera vez que usas Unity3D. Aquí explicaremos
cuáles son las secciones clave de la GUI (Interfaz gráfica de usuario) de Unity3D y describiremos la forma
de crear nuevos elementos y posicionarlos en las escenas de nuestro videojuego.
Para demostrar los aspectos esenciales del interfaz de Unity vamos a crear una escena 3D muy sencilla que
permitirá a un personaje caminar sobre una superficie.
Para facilitarte las cosas, siempre utilizaremos un guión (-) para prefijar todas las acciones que requieran
tu intervención directa con el programa.
2. Interfaz
Aunque existen otros modos de visualizar la interfaz, vamos a empezar con el más sencillo.
Asegúrate que el interfaz se encuentra en modo “2 by 3”.
 Para hacerlo, haz clic en las pestañas superiores: Window →Layout →2 by 3
Aunque en adelante trabajaremos siempre en modo “2 by 3”, el interfaz de Unity es totalmente configurable.
Todas sus ventanas pueden redimensionarse, cambiarse de posición y anclarse arrastrando y soltando sus
pestañas superiores. Observarás que el menú de Layout permite salvar la configuración de ventanas, algo
que nos será muy útil más adelante para guardar nuestra configuración favorita a la hora de animar, editar
terrenos, etc.
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 1
Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
Durante tus primeras experiencias con Unity 3D es frecuente que el interfaz pierda accidentalmente su
aspecto inicial y quieras regresar al modo 2 by 3. En esos casos recuerda siempre que el menú de Layout
también puede accederse fácilmente desde el botón en la esquina superior derecha de la interfaz. Observa a
continuación un ejemplo donde hemos guardado varios tipos de Layout personalizados:
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 2
Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
Volviendo al Layout “2 by 3”, verás que el interfaz está ahora dividido en estas 5 regiones principales que
puedes contrastar con la captura a pie de página:
1. Scene View – Es la vista de la escena de tu videojuego, y permite añadir nuevos objetos en ella,
seleccionarlos, editar el escenario, etc. En adelante la denominaremos Vista de Escena.
2. Game View – Es la vista del videojuego y muestra cómo se verá tu videojuego al ejecutarse. En
adelante la llamaremos Vista de Juego.
3. Hierarchy View – Es la vista de jerarquía y muestra la lista de todos los objetos que hay ahora
mismo en la escena, ordenados alfabéticamente. Nos permitirá seleccionarlos fácilmente a partir de
su nombre en lugar de buscarlos en la escena. En adelante la llamaremos Vista de Jerarquía.
4. Project View – Es la vista del proyecto y muestra la lista de todos los assets (Recursos) que hay
disponibles para usar en tu videojuego, ya sean sonidos, modelos 3D, texturas... En adelante la
llamaremos Vista de Proyecto.
5. Inspector View – Es la vista de inspección y muestra una lista con todas las propiedades del objeto
de tu videojuego que tienes seleccionado actualmente, permitiendo modificarlas. Si no tienes ningún
objeto seleccionado no nos mostrará nada. En adelante la llamaremos Vista de Inspector.
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 3
Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
3. Localizar objetos en el espacio 3D
Antes de continuar, vamos a reiniciar Unity3D para crear un nuevo proyecto con el que empezar
desde cero.
 Reinicia Unity3D (Cierra el programa y vuélvelo a abrir).
 Crea un nuevo proyecto haciendo clic en las pestañas superiores: File →New Project...
 Escribe un nombre para el proyecto, el que tú quieras, y haz clic en Create Project para continuar.
En este punto también puedes seleccionar una lista de paquetes de recursos que vienen por defecto
(Texturas, modelos, efectos de sonido, scripts, etc.) para que se encuentren disponibles en tu nuevo
proyecto. De momento selecciona solamente el paquete Character Controller, que es un paquete
muy básico con personajes.
Una vez finalice la carga de recursos podrás ver el “mundo” de tu videojuego. Por defecto sólo habrá en él
una cámara principal, la podrás ver como el único elemento en la lista de la Vista de Jerarquía, su nombre
es Main Camera y en adelante nos referiremos a ella como Cámara Principal.
 Vamos a trabajar en castellano siempre que nos sea posible, así que vamos a renombrar la Cámara
Principal. Para ello podemos hacer clic sobre su nombre en la Vista de Jerarquía, si a contiunación
hacemos otro clic nos permitirá cambiar su nombre. Otra opción es hacer clic derecho y
seleccionar Rename. Le pondremos como nombre “Cámara” y pulsaremos intro para terminar.
 Ahora comprueba la Vista de Escena. Si no puedes ver la cámara en ella, puedes hacer clic en ella en
la Vista de Jerarquía. Una vez hecho eso, si mueves el cursor dentro de la Vista de Escena, pulsando
la tecla F realizarás la opción de Seleccionar el Frame (Frame Select), que se encarga de centrar en
la escena el objeto seleccionado. Esta es la técnica que debemos seguir siempre que queramos
localizar un objeto en la escena. También puedes hacer simplemente doble clic en su nombre en la
Vista de Jerarquía para centrarla de la misma manera, y así con cualquier otro objeto.
 Observa en este punto que todos los objetos pueden ser seleccionados tanto haciendo clic sobre
ellos en la Vista de Escena como en la Vista de Jerarquía. Si seleccionas un objeto en la Vista de
Escena podrás comprobar si has seleccionado el objeto correcto porque se mostrará también
iluminado también en la Vista de Jerarquía.
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 4
Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
4. Creando objetos en el videojuego
A continuación vamos a añadir unos cuantos objetos en el mundo de nuestro videojuego.
 Selecciona la pestaña superior: Game Object →Create Other →Plane. Esto creará una superficie
bidimensional (Un plano) sobre el cuál podrá moverse nuestro personaje principal.
 Añade un cubo al mundo del videojuego seleccionando: Game Object →Create Other →Cube
 Añade una luz puntual seleccionando: Game Object →Create Other →Point Light
Todos los objetos que has creado aparecen por defecto en la misma posición, con una rotación neutra y sus
valores iniciales por defecto. A continuación vamos a ocuparnos de movernos por la escena, moverlos a una
posición determinada, rotarlos, etc.
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 5
Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
5. Navegando por la Vista de Escena
Aunque los controles son muy intuitivos y serás capaz de aprenderlos con la simple práctica, a
continuación detallamos cómo puedes recorrer el mundo de tu videojuego en la Vista de Escena y mirarlo
desde cualquier ángulo utilizando los siguientes controles:
1. Rotación – Clic derecho y arrastrar
2. Desplazamiento – Clic central (Presionar la rueda del ratón) y arrastrar. También con las teclas
direccionales
3. Zoom – Rueda del ratón, aunque es recomendable hacerlo por desplazamientos. Al hacer zoom con
la rueda del ratón se modifica la precisión de desplazamiento y abusar del zoom provocará que a
veces el desplazamiento sea demasiado lento o demasiado rápido. Si te es posible, evita usar la
rueda del ratón para hacer zoom.
Aunque no es lo habitual, si tu ratón es de un sólo botón, estás usando un touch pad o simplemente te resulta
más fácil, también puedes utilizar los siguientes controles alternativos siempre y cuando tengas
seleccionada la herramienta con icono en forma de mano que verás en la parte superior izquierda, justo
debajo de las pestañas superiores:
1. Rotación – Alt + Clic Izquierdo
2. Zoom – Control + Alt + Clic Izquierdo
 Prueba los controles anteriores hasta que te familiarices con ellos.
6. Mover los objetos del videojuego
Puedes modificar la posición, la rotación y el tamaño (Escala) de cualquier objeto que tengas
seleccionado en el espacio 3D. Los botones de la parte superior izquierda de la interfaz te permitirán
posicionar, rotar y escalar, respectivamente. Son los siguientes:
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 6
Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 7
Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
1. La herramienta Mover: También puede seleccionarse pulsando la tecla W. Si la pulsamos mientras tenemos
un objeto seleccionado, se mostrarán 3 flechas, una para cada eje en el espacio 3D. Los colores rojo, verde y
azul se corresponden con los ejes x, y, z, respectivamente. Para mover un objeto haz clic izquierdo en la
flecha que represente el eje en el que quieres mover el objeto y mueve el ratón para modificar su posición
hasta el punto que desees. Observa que al mismo tiempo que mueves el objeto, los valores de su posición
también cambian en el panel de la Vista de Inspector. También puedes introducir directamente los valores
numéricos en ese panel.
Otra forma más avanzada de modificar la posición de un objeto del videojuego es hacer clic sobre él para
seleccionarlo, y a continuación mover la Vista de Escena de forma que mire a la posición donde queremos
mover el objeto. Si hacemos clic en las pestañas superiores y seleccionamos: Game Object →Move to View,
el objeto se moverá a la posición a la que mira la cámara actualmente.
2. La herramienta Rotar: También puede seleccionarse pulsando la tecla E. Si seleccionamos un objeto del
videojuego y a continuación pulsamos esta tecla se mostrará la herramienta de rotación. Para rotar el
objeto sobre cualquiera de sus ejes, mantén presionado clic izquierdo sobre el eje que quieres rotar y mueve
el ratón. De la misma manera, el panel de la Vista de Inspector también cambiará sus valores al mismo
tiempo que rotas el objeto, y podrás introducirlos en él manualmente si lo deseas.
Otra forma más avanzada de modificar la rotación es mover la Vista de Escena de forma que mire en la
dirección con la que queremos alinear el objeto. Si hacemos clic en las pestañas superiores y
seleccionamos: Game Object →Align with View, el objeto se quedará alineado en la dirección a la que mira la
cámara de la Vista de Escena. Esto nos será sobre todo útil para orientar luces direccionales o cámaras
para que apunten a donde queremos.
 Vamos a hacer un pequeño ejercicio. Mueve el cubo con la herramienta Mover de manera que quede
fuera de la Vista de Escena. Usa ahora la opción de Seleccionar el Frame haciendo doble clic sobre el
cubo en la jerarquía (O bien pulsando la tecla F en la Vista de Escena). Finalmente intenta devolver el
cubo de nuevo hasta la posición del plano.
 Mueve ahora también la luz puntual de manera que se encuentre encima del cubo y el plano.
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 8
Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
La Vista de Escena de tu videojuego debería lucir aproximadamente de ésta manera si has realizado
correctamente los últimos pasos.
7. La Vista de Juego
Recuerda que la Vista de Juego nos muestra cómo se vería el videojuego en ejecución, con sus
texturas, iluminación final, etc. Si no puedes ver el mundo de tu videojuego en la Vista de Juego es porque tu
cámara no está mirando en la dirección correcta.
 Haz clic en la cámara principal. Verás que una malla en forma de pirámide blanca sale desde ella. Se
denomina campo de visión de la cámara y representa lo que ésta puede ver. Si el campo de visión no
apunta directamente a los objetos de tu videojuego, navega por al escena hasta localizarlos, una vez
hecho esto, vuelve a seleccionar la cámara en la jerarquía y haz clic en la pestaña superior: Game
Object →Align with View. De esta manera la cámara del videojuego se alineará exactamente en esa
posición y orientación, así la Vista de Videojuego coincidirá con la Vista de Escena.
Para casos concretos, recuerda que también puedes ajustar manualmente la configuración de la cámara
usando las herramientas de Mover y Rotar, o cambiando sus valores directamente en el panel del Vista de
Inspector.
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 9
Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
Quizás también desees mover la luz puntual para conseguir un efecto más estético.
8. Redimensionando objetos del videojuego
Para cambiar el tamaño de un objeto, selecciónalo en primer lugar y pulsa el botón correspondiente
en la parte superior izquierda de la interfaz, también puedes hacerlo pulsando la tecla R. Podrás escalar
visualmente cualquier objeto haciendo clic en el bloque con forma de pequeño cubo que aparece en el
extremo de cada eje, o bien usando la Vista de Inspector para teclear un valor preciso en él.
Ahora vamos a reescalar algunos objetos de nuestro videojuego:
 Selecciona el plano y pon a 10 los valores de escala tanto en el eje X como en el Z usando la Vista de
Inspector. Serán el primer y el tercer valor de la escala, ya que el segundo correspondería al eje Y y
los planos como tales no pueden agrandarse “hacia arriba”.
 Selecciona el cubo y redimensiónalo visualmente a lo largo del eje Y subiendo hacia arriba el bloque
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 10
Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
con forma de cubo en ese eje de forma que el cubo termine pareciéndose a un pilar.
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 11
Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
 Renombra el cubo como “Pilar”. Recuerda que puedes hacer ésto seleccionándolo en la Vista de
Jerarquía, haciendo clic derecho sobre él y seleccionando la opción Rename (Renombrar). Tras
escribir el nombre que desees, pulsa Enter para guardarlo. Recuerda que es recomendable que los
nombres de los objetos del videojuego comiencen con letra mayúscula.
 Aprovecha nuevamente en este punto para poner nombres en castellano a todos los objetos de la
escena. Es una muy buena práctica utilizar un lenguaje común y conocer bien todos los objetos que
hay en tu proyecto.
9. Utilizando los Recursos
Un videojuego está compuesto por modelos 3D, texturas, archivos de sonido, código fuente, etc.
Estos elementos se denominan Recursos (Assets). Unity3D viene con muchos recursos de serie, incluso más
en la versión pro, y también pueden descargarse gran cantidad de ellos en internet.
Recuerda que a la hora de crear el proyecto seleccionamos un paquete llamado Character Controllers para
incluirlo como recurso. Ahora es el momento de utilizarlo.
Vamos a añadir a nuestro videojuego uno de los personajes
prefabricados que podemos encontrar en los Recursos. En la Vista
de Proyecto expande el directorio llamado Standard Assets
(Recursos Estándar) y a continuación expande el subdirectorio
Character Controllers (Controladores de Personaje). Como
peculiaridad, verás que para expandir un directorio debes pulsar el
icono en forma de triángulo que hay a la izquierda de su icono de
carpeta.
Todos los Standard Assets que vienen con Unity son colecciones de objetos de videojuego (Scripts, modelos,
texturas...) que han sido previamente ensamblados entre ellos con una agrupación lógica. Como verás más
adelante estas agrupaciones de objetos se denominan Prefabs y son fundamentales para trabajar con Unity
de manera eficiente. En el subdirectorio Character Controlers verás un Prefab llamado First Person
Controller (Controlador de Primera Persona).
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 12
Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
 Arrastra el First Person Controller en la Vista de Escena. Observa como la Vista de Videojuego
cambia, esto es porque el FPS Controller prefabricado viene con su propia cámara, la cual toma
precedencia frente la Cámara Principal que existía desde un principio. Asegúrate de que el First
Person Controller no está atrapado dentro del plano, para ello muévelo de forma que quede sobre el
plano.
 Borra la Cámara Principal (Main Camera) ya que no la vamos a volver a necesitar, puedes hacerlo
pulsando la tecla Supr con ella seleccionada o bien haciendo clic derecho sobre ella en la Vista de
Jerarquía y seleccionando la opción Delete. La Vista de Videjuego a partir de ahora será lo que el
jugador puede ver dentro del juego.
 Arranca el videojuego clicando el botón Play que puedes ver en la parte superior central de la GUI de
Unity. Observa que la pantalla permanece igual, de forma que puedes ver el videojuego dentro de la
Vista de Escena y la Vista de Videojuego. Usa las teclas cursor para mover a tu personaje por el
entorno (También puedes usar A,S,D,W), usa el ratón para mirar a tu alrededor y la tecla espacio
para saltar.
 Puedes detener la ejecución del videojuego en cualquier momento pulsando nuevamente el botón
Play o bien hacer una simple pausa utilizando el botón de Pausa.
En este punto es interesante que sepas que pulsando la barra espaciadora mientras el cursor se encuentra
dentro de cualquiera de las distintas Vistas de Unity3D (Videojuego, Escena, etc.), dicha Vista pasará a modo
pantalla completa. Esto resulta útil cuando se están haciendo ajustes en la Vista de Escena, o cuando se está
probando el juego desde la Vista de Videojuego. Pulsando el espacio de nuevo dentro de la pantalla completa,
ésta volverá a su modo normal de visualización. Esta característica está desactivada mientras el videojuego
se encuentra en ejecución, en ese caso debes detener o simplemente pausar el videojuego primero.
10. Añadiendo componentes
Los objetos de tu videojuego pueden tener cierto número de componentes (También llamados
comportamientos) asociados. Al hacer clic en un objeto del videojuego, puedes ver los componentes
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 13
Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
asociados en su Vista de Inspector (p.ej. Luces, colisionadores, etc.).
 Haz clic en el Pilar y mira sus componentes asociados en la Vista de Inspector.
Vamos a añadir otro cubo más a la escena y añadir un componente adicional.
 Añade otro cubo a la escena (Game Object →Create Other →Cube). Renómbralo como “Cubo con
Gravedad” en la Vista de Jerarquía.
Ahora vamos a añadir un Rigidbody (Cuerpo rígido) al cubo. Este tipo de componente permite al objeto del
videojuego comportarse como si estuviese dentro de un mundo con gravedad. Por ejemplo, el objeto caerá
hacia abajo hasta que golpee una superficie que tenga un componente asociado de tipo Collider, por ejemplo
el Plano.
 Asegúrate de que tienes el Cubo con Gravedad seleccionado, selecciona entonces Component →
Physics →Rigidbody. Esto añadirá el componente Rigidbody al objeto del videojuego que tengas
seleccionado. Observa que en la Vista de Inspector el componente también aparecerá añadido.
 Mueve el Cubo con Gravedad de forma que se encuentre sobre el Pilar, a una poca distancia sobre él.
Queremos configurar la escena de forma que, cuando pulsemos Play, El Cubo con Gravedad colisione
con el Pilar y después caiga al suelo.
 Pulsa ahora el botón Play, el Cubo con Gravedad debería colisionar contra el Pilar y a continuación
caer sobre el plano comportándose como si hubiese gravedad.
11. Duplicar
Duplicar un objeto del videojuego es la característica más potente de Unity. Cuando duplicamos un
objeto, todas las características y comportamientos del objeto son a su vez copiados. Es una forma muy
rápida de crear escenas complejas con multitud de objetos. Ahora vamos a añadir más Cubos con Gravedad
a nuestra escena.
 Haz clic en el Cubo con Gravedad para asegurarte de que lo tienes seleccionado.
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 14
Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
 Pulsa Ctrl+D (También puedes hacerlo desde el menú Edit, o simplemente haciendo clic derecho
sobre él en la Vista de Jerarquía y seleccionando la opción Duplicate). Observa cómo aparece una
nueva entrada con un Cubo con Gravedad adicional en la Vista de Jerarquía. Observa que sin
embargo, no puedes verlo, ya que ha sido creado exactamente sobre la misma posición que el
anterior.
 Mueve el nuevo Cubo con Gravedad seleccionando la herramienta mover (O pulsando la tecla W) y
muévelo hacia arriba en el eje Y.
 Repite este proceso de forma que haya varios Cubos con Gravedad en la escena, unos sobre otros
formando alguna estructura que resulte divertida de ver al derrumbarse.
 Ejecuta ahora el videojuego y los Cubos con Gravedad interactuarán entre ellos comportándose con
total naturalidad.
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 15
Tutorial de Unity 3D
Tema 1
Introducción a la GUI de Unity3D
Tutorial de Unity 3D Introducción a la GUI de Unity3D
Pág. 16
Descargar

Introduccion a l..

Donde surgen las sombras. David Lozano Garbala

Donde surgen las sombras. David Lozano Garbala

PersonajesVideojuegos en la vida realJuegos de rolArgumentoAsesinatosSiglo XXIAmistadLiteratura española juvenil contemporáneaNovela de misterio, intriga y terrorDesapariciones

Clima social en el aula

Clima social en el aula

MaestrosEducaciónAlumnosEntornoPedagogíaContenidosTareasEscuelaComportamientoAdministración educativaAprendizajeEnseñanza

Tutoría y orientación

Tutoría y orientación

EducaciónAlumnosJuventudProfesoresPedagogíaProgramasAdolescenciaConsulta triádicaServiciosModelo clínicoPersonalidad