INGENIERÍA INFORMÁTICA EXAMEN DE REDES
PRIMER PARCIAL. FEBRERO 2006
SOLUCIÓN
Primera Parte. Teoría y Laboratorio
----------------------------------------------------------------------------------------------------------------------------- 1.1
¿Cual de las siguientes características está siempre presente en los conmutadores LAN?
A) El soporte del protocolo Spanning tree
B) El soporte de VLANs
C) La conmutación por hardware
D) Todas las anteriores
1.2
¿Cuál es el número máximo de conmutadores por los que puede pasar una trama Ethernet?
A) Siete
B) Ilimitado
C) Depende del valor del campo TTL
D) Depende de la configuración de los equipos
1.3
La principal razón para crear VLANs, reduciendo así el número máximo de ordenadores en cada
LAN, es:
A) Evitar que se supere el número máximo de entradas en las tablas de direcciones MAC de los
conmutadores
B) Evitar que el número de colisiones crezca excesivamente
C) Evitar que el tráfico broadcast crezca excesivamente
D) Evitar superar el valor máximo de 1024 estaciones permitidas en una red Ethernet
1.4
Una LAN conmutada (sin VLANs) está formada por cinco conmutadores entre los que hay siete
conexiones punto a punto. Todos los conmutadores están ejecutando el protocolo Spanning Tree.
¿Cuantos puertos se han bloqueado?
A) Tres
B) Cuatro
C) Cinco
D) Seis
1.5
¿Para que sirve el estándar 802,1Q?:
A) Para permitir la autonegociación entre equipos de distintos fabricantes
B) Para permitir la configuración de VLANs entre conmutadores de distintos fabricantes
C) Para permitir el uso de enlaces trunk entre conmutadores de distintos fabricantes
D) Para permitir el uso del Spanning Tree entre conmutadores de distintos fabricantes
1.6
La principal diferencia entre los conmutadores y los puentes transparentes es:
A) La posibilidad de configurar VLANs
B) La utilización del protocolo Spanning Tree
C) La velocidad de conmutación
D) La posibilidad de separar dominios de colisión
1.7
¿Cual es el principal objetivo del routing dinámico?
A) Reaccionar ante situaciones cambiantes (caídas, saturación de enlaces, etc.)
B) Realizar el cálculo de las rutas óptimas de forma centralizada
C) Reducir el tráfico de gestión de la red
D) Ninguna de las anteriores
1
1.8
Una red de área extensa está formada por un conjunto de enlaces punto a punto de 2 Mb/s, 512
Kb/s y 64 Kb/s. Se sabe que el tiempo medio de servicio para paquetes de un mismo tamaño es
similar en todos los enlaces. Si lo expresamos en términos relativos, ¿Qué enlaces tendrán un
mayor grado de ocupación?
A) Los de 64 Kb/s
B) Los de 2 Mb/s
C) Todos por igual
D) No es posible estimarlo a partir de la información facilitada
1.9
¿En cual de las siguientes situaciones sería adecuado utilizar un algoritmo de routing basado en el
flujo?
A) En el diseño de la topología de una red de circuitos punto a punto
B) En el diseño de la topología de una red de circuitos virtuales ATM
C) En el diseño de la topología de una red de circuitos virtuales Frame Relay
D) En todos los anteriores
1.10
¿Cual de las siguientes características es propia de las redes con servicio CLNS (ConnectionLess
Network Service)?
A) La ruta óptima se elige al principio de la conexión y se mantiene inalterada durante toda la
vida de ésta
B) Cada paquete lleva la dirección de destino
C) El orden de envío de los paquetes se mantiene en todo el trayecto
D) Si un router queda fuera de servicio la conexión queda interrumpida, aun en el caso de tener
una red mallada
1.11
¿En que algoritmo de routing puede darse da el problema conocido como ‘cuenta a infinito’?
A) En el de vector distancia
B) En el de Estado del enlace
C) En el ‘Open Shortest Path First’
D) En el routing basado en el flujo
1.12
¿En que tipo de redes puede aplicarse el mecanismo de control de congestión denominado
“Control de Admisión”?
A) En redes con servicio orientado a conexión
B) En redes con servicio no orientado a conexión
C) En redes basadas en datagramas
D) En todas las redes
1.13
La finalidad del campo checksum en la cabecera IP es:
A) Proteger la cabecera de errores que se puedan producir en la transmisión por los enlaces
B) Proteger la cabecera de errores que se puedan producir en el interior de los routers
C) Proteger a todo el paquete (cabecera y datos) de errores que se puedan producir en la
transmisión por los enlaces.
D) Proteger a todo el paquetede errores que se puedan producir en el interior de los routers.
1.14
Cuales de las clases originalmente definidas en Internet se abolieron cuando se aprobó el estándar
denominado CIDR (Classless Inter. Domain Routing)?
A) Todas
B) A, B, C y D
C) A, B y C
D) C
1.15
Suponga que en un router se definen únicamente las dos rutas estáticas siguientes:
A 10.0.0.0/8 por 11.11.11.2
A 10.0.0.0/8 por 11.11.11.6
2
¿Qué ocurre cuando se envían paquetes a direcciones de la red 10.0.0.0/8?
A) Se utiliza solo la primera ruta definida (en este caso la que va por 11.11.11.2)
B) El router reparte el tráfico entre las dos rutas
C) Se utiliza la ruta de dirección IP más baja (en este caso la 11.11.11.2)
D) No es posible definir dos rutas hacia una misma red con la misma distancia administrativa
pues al definir la segunda el router da un error y dice que ya existe una ruta para esa red
1.16
Indique cual de las siguientes declaraciones de ruta es incorrecta
A) A 200.200.200.200/30 por 12.13.14.15
B) A 140.140.0.0/24 por 112.150.150.0
C) A 100.100.101.0/23 por 103.104.105.106
D) A 120.120.120.0/25 por 110.110.110.110
1.17
La finalidad de los mensajes ICMP Redirect es:
A) Evitar que se produzcan bucles en la red
B) Reducir la cantidad de mensajes ARP request emitidos en la red
C) Reducir el número de routers por los que pasa un paquete para llegar a su destino
D) Permitir que los paquetes lleguen a su destino cuando en el host no se ha definido ninguna
ruta (ni router por defecto).
1.18
¿Cual de los siguientes protocolos no utiliza el Ethertype X’0800’ (correspondiente a IP) cuando
se envía por una red Ethernet?
A) ARP
B) BOOTP
C) DHCP
D) ICMP
1.19
¿Qué dirección de origen lleva un paquete DHCP Request?
A) 0.0.0.0
B) 255.255.255.255
C) La que se ha configurado en el equipo que emite el paquete
D) La que corresponde a la dirección MAC de ese equipo en la tabla del servidor DHCP
1.20
Un datagrama IP que tiene 900 bytes de datos (más la cabecera) se fragmenta en tres trozos antes
de llegar a su destino. ¿Cuantos bytes recibirá en total (contando cabeceras) el host de destino?
Suponga que la cabecera IP del datagrama original no tiene campos opcionales
A) 940
B) 944
C) 960
D) 964
1.21
Una ventaja de OSPF respecto de EIGRP es que:
A) Incorpora métricas sofisticadas
B) Puede utilizar rutas asimétricas
C) Permite establecer niveles jerárquicos
D) Soporta subredes
1.22
¿Por qué motivo se utilizan entre sistemas autónomos protocolos de routing diferentes a los
empleados dentro de un sistema autónomo?
A) Porque se emplean algoritmos diferentes
B) Porque la cantidad de routers y rutas involucrados no se podría manejar con los protocolos
utilizados dentro de un sistema autónomo.
C) Porque se utilizan métricas más complejas que las empleadas dentro de un sistema autónomo
D) Porque se quiere poder establecer restricciones para impedir el paso de cierto tráfico
por determinados sistemas autónomos
3
1.23
Que se entiende en el ámbito de Internet por ‘acuerdo de peering’
A) Acuerdo por el cual un ISP conecta a una empresa a Internet a cambio de una cuota
B) Acuerdo por el cual dos ISPs intercambian tráfico entre ellos sin restricciones y sin costo
para ninguno de ambos
C) Acuerdo por el cual un ISP se conecta a un punto neutro de interconexión
D) Acuerdo por el cual una empresa ‘multihomed’ se conecta a dos ISPs para mejorar la
fiabilidad de su conexión
1.24
¿En que se diferencia el checksum de la cabecera de IPv6 del de IPv4?
A) En que en IPv6 no existe
B) En que su uso en IPv6 es opcional (si no se usa se pone a cero)
C) En el algoritmo utilizado para calcularlo
D) En su longitud. El de IPv6 es mas largo
1.25
Diga cual de las siguientes especificaciones de ruta IPv6 es incorrecta:
A) A 2001:720:1030::/48 por 2001:720:1026:202:8:2FF:FE67:5CCA
B) A 2001:720:1030::/56 por 2001:720:1026:202:8:2FF:FE67:5CCA
C) A 2001:720:1030::/60 por 2001:720:1026:202:8:2FF:FE67:5CCA
D) A 2001:720:1030::/80 por 2001:720:1026:202:8:2FF:FE67:5CCA
4
Pregunta 2.1 (1 punto):
Conmutador raíz: ID 18
Puertos raíz de los conmutadores no raíz:
 Conmutador 25: puerto 1
 Conmutador 29: puerto 2
 Conmutador 34: puerto 1
Puertos designados de cada LAN:
 LAN A: puerto 3 de ID 18
 LAN B: puerto 1 de ID 18
 LAN C: puerto 2 de ID 18
 LAN D: puerto 2 de ID 25
 LAN E: puerto 3 de ID 25
Puertos bloqueados:
 Puerto 2 de ID 34
 Puerto 1 de ID 29
Puente raíz
LAN A
3 (D)
ID 18
1 (D)
1 (R)
ID
2 (D)
2 (D)
LAN C
LAN D
3 (D)
LAN E
LAN B
1 (R)
ID 34
2 (B)
1 (B)
2 (R)
ID
5
INGENIERÍA INFORMÁTICA EXAMEN DE REDES.
PRIMER PARCIAL. FEBRERO 2006
Laboratorio
Pregunta L1.
-----------------------------------------------------------------------------------------------------------------------------L.1
¿En que estado de spanning tree se encuentra una interfaz de un conmutador cuando desempeña la
función de conmutación de tramas?:
A)
B)
C)
D)
L.2
Learning
Forwarding
Switching
Redirecting
¿Cuál es la consecuencia de borrar las entradas en la tabla de direcciones MAC de un
conmutador?:
A) El conmutador descarta las tramas que le llegan entretanto no aprende de nuevo a que puerto
corresponde cada dirección MAC
B) Reenvía las tramas por todos los puertos entretanto no aprende de nuevo a que puerto
corresponde cada dirección MAC
C) Reenvía las tramas por todos los puertos entretanto no aprende de nuevo a que puerto
corresponde cada dirección MAC. Además los hosts envían mensajes ARP Request para
poder averiguar la correspondencia IP-MAC y acelerar así el aprendizaje del conmutador.
D) Descarta las tramas que le llegan entretanto no aprende de nuevo a que puerto corresponde
cada dirección MAC. Además los hosts envían mensajes ARP Request para poder averiguar la
correspondencia IP-MAC y acelerar así el aprendizaje del conmutador.
L.3
¿En cual de los siguientes casos podemos asegurar que el contador de colisiones de una interfaz en
un conmutador no se incrementará?
A) Solo cuando podemos asegurar que no hay ningún tráfico, es decir cuando la interfaz no tiene
conectado ningún equipo
B) Si la interfaz está configurada como full duplex, independientemente de cómo esté
configurado el equipo conectado a ella.
C) Si el equipo conectado está configurado como full dúplex, independientemente de cómo esté
configurada la interfaz del conmutador
D) Solo si tanto la interfaz como el equipo a ella conectado están configurados como full dúplex
L.4
En la práctica 1 (segunda sesión) se crean dos VLANs en los dos conmutadores (norte y sur) y se
interconectan éstos, primero mediante un cable directo que une un puerto de cada VLAN, luego
mediante un router en el conmutador norte y luego se añade un segundo router en el conmutador
sur. ¿Que cambio se realiza en la configuración IP al añadir el segundo router?
A) Se crean dos subredes IP diferentes, una para cada conmutador y se modifican las direcciones
IP de todos los hosts
B) Se crean una subred IP nueva para los ordenadores del conmutador sur y se modifican las
direcciones IP de los hosts de ese conmutador
C) Se cambia el router por defecto en todos los ordenadores
D) Se cambia el router por defecto en los ordenadores del conmutador sur
L.5
Cuando en la práctica 1 (sesión 2) configuramos las VLANs pares y nones en los conmutadores,
¿Qué ocurre con el acceso vía telnet a la dirección IP que habíamos configurado para la gestión del
conmutador?:
A) Se puede acceder desde cualquier ordenador, como antes de configurar las VLANs
B) No se puede acceder entretanto no se asigne la gestión a alguna de las dos VLANs
6
C) Se puede acceder desde ordenadores de la VLAN nones, por estar asignado el puerto 1 a dicha
VLAN
D) Se puede acceder solo desde el ordenador conectado al puerto 1, que es el que está
configurado para el acceso de gestión cuando hay VLANs configuradas.
L.6
¿Qué datos se utilizan en la configuración por defecto de EIGRP para calcular la métrica de una
ruta?
A) El retardo y el ancho de banda de todas las interfaces por las que pasa dicha ruta
B) Se utiliza el retardo de todas las interfaces, pero para el ancho de banda se elige el de la
interfaz con menor ancho de banda de toda la ruta
C) El ancho de banda de todas las interfaces, pero para el retardo se elige el de la interfaz con
mayor retardo de toda la ruta
D) Se utiliza el ancho de banda de la interfaz con menor ancho de banda de toda la ruta y el
retardo de la interfaz con mayor retardo de toda la ruta.
L.7
En un router se han configurado las siguientes rutas estáticas:
a) ip route 172.16.32.0 255.255.255.0
10.0.0.1
b) ip route 172.16.32.0 255.255.255.128 10.0.0.2 100
c) ip route 172.16.32.5 255.255.255.255 10.0.0.3 50
¿Cual de ellas se utilizará para enviar un datagrama a la dirección 172.16.32.5? Suponga que no se
utiliza ningún protocolo de routing
A)
B)
C)
D)
L.8
¿Que comando utilizaría para averiguar las conexiones TCP establecidas en un host?
A)
B)
C)
D)
L.9
La a)
La b)
La c)
La elección depende de la métrica de cada ruta. Suponiendo la misma métrica en todas ellas
sería la a)
traceroute
netstat
host
ifconfig
¿Que comando utilizaría para modificar la dirección MAC de una tarjeta de red?
A)
B)
C)
D)
traceroute
netstat
host
ifconfig
L.10 ¿Que comando utilizaría para averiguar si la tarjeta de red de un host está detectando errores de
CRC en las tramas que recibe?
A)
B)
C)
D)
traceroute
netstat
ethtool
ping
Pregunta L 2.1.
7
Equipo
RP
HP1
HP2
RS1
HS1
RS2
HS2
Interfaz
Fast Ethernet 0
Ethernet 0
Serial 0
Serial 1
Eth0
Eth0
Fast Ethernet 0
Serial 0
Serial 1
Eth0
Fast Ethernet 0
Serial 0
Serial 1
Eth0
Red
10.0.0.0/24
10.0.1.0/24
10.0.4.0/30
10.0.4.4/30
10.0.0.0/24
10.0.1.0/24
10.0.2.0/24
10.0.4.0/30
10.0.4.8/30
10.0.2.0/24
10.0.3.0/24
10.0.4.4/30
10.0.4.8/30
10.0.3.0/24
Dirección IP
10.0.0.1
10.0.1.1
10.0.4.1
10.0.4.5
10.0.0.2
10.0.1.2
10.0.2.1
10.0.4.2
10.0.4.9
10.0.2.2
10.0.3.1
10.0.4.6
10.0.4.10
10.0.3.2
Pregunta L 2.2.
RP>enable
RP#configure terminal
RP(config)#interface F0
RP(config-if)#ip address 10.0.0.1
RP(config-if)#no shutdown
RP(config-if)#interface E0
RP(config-if)#ip address 10.0.1.1
RP(config-if)#no shutdown
RP(config-if)#interface S0
RP(config-if)#ip address 10.0.4.1
RP(config-if)#clock rate 128000
RP(config-if)#no shutdown
RP(config-if)#interface S1
RP(config-if)#ip address 10.0.4.5
RP(config-if)#no shutdown
RP(config-if)#CTRL/Z
255.255.255.0
255.255.255.0
255.255.255.252
255.255.255.252
RP#
8
INGENIERÍA INFORMÁTICA. EXAMEN DE REDES.
PRIMER PARCIAL, FEBRERO 2006
Segunda Parte. Problemas
Problema 1.
ping –n –c 1 11.0.0.4
Protoc.
ARP
MAC
Origen
X
MAC
Destino
Broadcast
IP origen
IP destino
ARP
Y
X
IP
X
Y
11.0.0.2
11.0.0.4
IP
Y
X
11.0.0.4
11.0.0.2
Ruta LAN
Contenido
C recibe
por 2, envía
por 1, 3 y 4
C recibe
por 3, envía
por 2
C recibe
por 2, envía
por 3
C recibe
por 3, envía
por 2
ARP Request
¿Quién es
11.0.0.4?
ARP
Response
Ruta LAN
Contenido
C recibe
por 2, envía
por 1, 3 y 4
C recibe
por 1, envía
por 2
C recibe
por 2, envía
por 1
D recibe
por 2, envía
por 1
D recibe
por 1, envía
por 2
D recibe
por 2, envía
por 1
D recibe
por 1, envía
por 2
C recibe
por 1, envía
por 2
ARP Request
¿Quién es
11.0.0.1?
ARP
Response
ICMP Echo
Request
ICMP Echo
Reply
ping –n –c 1 10.0.0.2
Protoc.
ARP
MAC
Origen
X
MAC
Destino
Broadcast
IP origen
ARP
A-Eth0
X
IP
X
A-Eth0
ARP
A-Eth1
Broadcast
ARP
Z
A-Eth1
IP
A-Eth1
Z
11.0.0.2
10.0.0.2
IP
Z
A-Eth1
10.0.0.2
11.0.0.2
IP
A-Eth0
X
10.0.0.2
11.0.0.2
11.0.0.2
IP destino
10.0.0.2
ICMP Echo
Request
ARP Request
¿Quién es
10.0.0.2?
ARP
Response
ICMP Echo
Request
ICMP Echo
Reply
ICMP Echo
Reply
ping –n –c 1 10.0.0.4
9
Protoc.
IP
MAC
Origen
X
MAC
Destino
A-Eth0
ARP
A-Eth1
Broadcast
IP
A-Eth0
X
IP origen
IP destino
Ruta LAN
Contenido
11.0.0.2
10.0.0.4
C recibe
por 2, envía
por 1
D recibe
por 2, envía
por 1
C recibe
por 1, envía
por 2
ICMP Echo
Request
11.0.0.1
11.0.0.2
ARP Request
¿Quién es
10.0.0.4?
ICMP
Destino
Inaccesible
En este caso el ping no funciona.
Problema 2.
10.0.4.0/24
Rtr: 10.0.4.1
10.0.0.0/23
Rango 10.0.0.*
Rtr: 10.0.0.1
A 10.0.4.0/24 por 10.0.2.2
Z
A
X
Eth1
10.0.2.1/24
A 10.0.0.0/24 por 10.0.2.1
A 10.0.1.0/24 por 10.0.3.1
Eth0
10.0.0.1/24
Eth0
10.0.2.2/24
Eth2
10.0.4.1/24
C
Eth1
10.0.3.2/24
Eth0
10.0.1.1/24
Y
10.0.1.0/23
Rango 10.0.1.*
Rtr: 10.0.1.1
B
Eth1
10.0.3.1/24
A 10.0.4.0/24 por 10.0.3.2
Para conseguir que los hosts X e Y se puedan comunicar directamente se colocan en una misma red (la
10.0.0.0/23) pero para que utilicen una ruta diferente al comunicar con el host Z les asignamos diferente
rango (10.0.0.* para los X y 10.0.1.* para los Y) y diferente router por defecto (A a X y B a Y). Además
en el router C se definen dos rutas diferentes según el destino sea la red formada por los hosts A o la
formada por los hosts B.
Otra posible solución habría sido definir redes completamente independientes para X e Y, y comunicarlas
entre sí definiendo una IP secundaria de Y en A y de X en B. Pero esta solución habría requerido que para
la comunicación de X con Y se pasara por uno de los routers, y además las rutas no sería simétricas (el
camino de X hacia Y pasaría por A y el de vuelta por B). Por tanto esta solución no cumple todos los
requisitos planteados en el enunciado.
10
Descargar

116 KB

Conmutación digital

Conmutación digital

InformáticaRed de conexión digitalTransmisión ditialCentrales de conmutaciónTerminal de abonadoConversiones eléctricasCanales digitalesConmutador analógicoSwitchesBridges

Métodos de conmutación

Métodos de conmutación

InformáticaElectrónicaMultietapaCircuitoTransmisión de datosPlegadoRed conmutadaBarras cruzadasConmutador